nixfleet/hmModules/whatsapp/default.nix
Andrea Ciceri a394b9cefd
All checks were successful
/ test (push) Successful in 32s
Reformat everything
2024-09-20 11:37:17 +02:00

19 lines
411 B
Nix

{ pkgs, ... }:
{
home.packages = [ pkgs.whatsapp-for-linux ];
systemd.user.services.whatsapp = {
Install.WantedBy = [ "graphical-session.target" ];
Unit = {
Description = "Whatsapp";
PartOf = [ "graphical-session.target" ];
};
Service = {
ExecStart = "${pkgs.whatsapp-for-linux}/bin/whatsapp-for-linux";
Restart = "on-failure";
RestartSec = 3;
};
};
}