nixfleet/hmModules/pantalaimon/default.nix
2025-03-06 13:07:17 +01:00

27 lines
697 B
Nix

{ pkgs, lib, ... }:
{
services.pantalaimon = {
enable = true;
package = pkgs.pantalaimon.overrideAttrs {
pytestCheckPhase = "echo skip pytest";
};
settings = {
Default = {
LogLevel = "Debug";
SSL = true;
};
local-matrix = {
Homeserver = "https://matrix.aciceri.dev";
# Homeserver = "https://matrix.nixos.dev/_matrix/client";
# Homeserver = "https://matrix.nixos.dev";
ListenAddress = "localhost";
ListenPort = 8008;
# SSL = false;
UseKeyring = false;
# IgnoreVerification = true;
};
};
};
systemd.user.services.pantalaimon.Unit.Requires = [ "dbus.socket" ];
}