This repository has been archived on 2024-10-30. You can view files and clone it, but cannot push or open issues or pull requests.
emacs/flake.nix
Andrea Ciceri 6cc0c0f094
Some checks failed
/ test (push) Failing after 14s
Things
2024-09-16 09:47:49 +02:00

43 lines
1.1 KiB
Nix

{
description = "My opinionated Emacs";
inputs = {
flake-parts.url = "github:hercules-ci/flake-parts";
emacs-overlay.url = "github:nix-community/emacs-overlay";
nixpkgs.follows = "emacs-overlay/nixpkgs";
hercules-ci-effects.url = "github:hercules-ci/hercules-ci-effects";
extra-package-indent-bars = {
url = "github:jdtsmith/indent-bars";
flake = false;
};
extra-package-notmuch-notify = {
url = "github:firmart/notmuch-notify";
flake = false;
};
extra-package-copilot = {
url = "github:zerolfx/copilot.el";
flake = false;
};
extra-package-haskell-ts-mode = {
url = "git+https://codeberg.org/pranshu/haskell-ts-mode.git";
flake = false;
};
extra-package-typst-ts-mode = {
url = "git+https://codeberg.org/meow_king/typst-ts-mode.git";
flake = false;
};
};
outputs = inputs @ {flake-parts, ...}:
flake-parts.lib.mkFlake {inherit inputs;} {
systems = ["x86_64-linux" "aarch64-linux"];
imports = [
./packages
./hmModules
./formatter
# ./diff-closures
./checks
./ci
];
};
}